Climbing a steeper hill? Sub-Saharan Africa’s recent development and business prospects

27 June, 2016 03:00 PM CET [15:00] (Brussels), 09:00 AM ET [09:00] (New York), 01:00 PM UTC [13:00] | Special Webcast

Join this webcast to learn about various business environments in Africa in terms of challenges and opportunities.

6 Things You Need To Know To Successfully Navigate The New Digital Economy

06 July, 2016 03:00 PM CET [15:00] (Brussels), 09:00 AM ET [09:00] (New York), 01:00 PM UTC [13:00] | Special Webcast

This webcast will explore the impact of digitization on productivity, growth, and labor markets and offer insights into the challenges and opportunities digitization brings for businesses.

How Does Your State Compare? Labor Shortages in the US

13 July, 2016 01:00 PM ET [13:00] (New York), 05:00 PM UTC [17:00] | KnowlEdge Series

Labor shortages will affect not only which jobs are experiencing labor shortages but where those jobs are located. This webcast examines the differences in labor shortages by state and regions in the US. HRCI, SHRM, and CPE credit available

Labor Shortages Abroad: Which countries will experience a tight labor market soon?

02 August, 2016 11:00 AM ET [11:00] (New York), 03:00 PM UTC [15:00] | KnowlEdge Series

Which countries are expected to face labor shortages? This webcast will analyze which mature and emerging markets will most likely experience labor shortages in the coming years. CPE, HRCI, and SHRM credit available

Consumer Demand in an Under Pressure Economy

30 August, 2016 02:00 PM ET [14:00] (New York), 06:00 PM UTC [18:00] | Special Webcast

Join The Demand Institute®, a not-for-profit think tank jointly operated by The Conference Board and Nielsen, and The Federal Reserve Bank of New York for a special webcast on the US consumer. CPE credit available

On Demand Webcast of the Week:

The Conference Board Economics Watch® - Emerging Markets View

Webcast Information

Webcast Help

Frequently Asked Questions

Customer Service

Flash Information

To view our webcasts Flash Player 9.0.28 and above is required.

Detect My Version

Upgrade Flash Player