Europe Monthly Series

Sign In to access this Webcast

Sign In

This webcast discusses the borrowing environment for firms and small businesses in
Euro Area economies. It also examines how effective ECB monetary policy has been in providing lower rates for the privates sector.


Bart van Ark, Ph.D.

Bart van Ark, Ph.D.
Executive Vice President, Chief Economist & Chief Strategy Officer
The Conference Board

Bart van Ark is executive vice president, chief economist & chief strategy officer of The Conference Board. He leads a team of almost two dozen economists in New York, Brussels and Beijing who produce a range of widely watched economic indicators and growth forecasts and in-depth global econo...Full Bio

Brian Schaitkin

Brian Schaitkin
The Conference Board

Brian Schaitkin is an economist at The Conference Board. Schaitkin joined The Conference Board in 2007 as a research analyst for the Global Indicators Research Institute program. Schaitkin helped develop The Conference Board Leading Economic Index® (LEI) for the Euro...Full Bio

Bert Colijn

Bert Colijn
Senior Economist, Europe
The Conference Board

Bert Colijn is a senior economist that focuses on the European market. He works on the European Commission FP7 project NEUJOBS, focusing on productivity and economic growth in Europe in 2025. Besides this, he works on developing European indicators and analysis of the European economies.

...Full Bio

Fernando Navarrete

Fernando Navarrete

Fernando Navarrete, Chief Financial Officer of Instituto de Crédito Oficial (ICO), is responsible for designing and evaluating general steps of action policies of the institute, manages the process of obtaining the necessary resources in the market for the credit activity of ICO, and coord...Full Bio

Members: Sign in to see if this product is complimentary with your membership.
Non-members: Not available
(Find out how to become a member
Watch the Trailer
Webcast Information

Webcast Help

Frequently Asked Questions

Customer Service

Flash Information

To view our webcasts Flash Player 9.0.28 and above is required.

Detect My Version

Upgrade Flash Player